티스토리 뷰

.NET Framework 4.5.2, 4.6 및 4.6.1은 2022년 4월 26일에 지원이 종료 됩니다. 이 날짜가 지나면 이러한 버전에 대한 보안 수정 또는 기술 지원을 포함한 업데이트를 더 이상 제공하지 않습니다.

 

현재 .NET Framework 4.5.2, 4.6 또는 4.6.1을 사용하고 있는 고객은 업데이트 및 기술 지원을 계속 받으려면 배포된 런타임을 2022년 4월 26일 이전에 .NET Framework 4.6.2보다 최신 버전으로 업데이트해야 합니다.

 

*Windows 10 Enterprise LTSC 2015는 OS에 내장된 .NET Framework 4.6과 함께 제공됩니다. 이 OS 버전은 LTSC(장기 서비스 채널) 릴리스입니다. OS 버전 지원 종료(2025년 10월)까지 Windows 10 Enterprise LTSC 2015에서 .NET Framework 4.6을 계속 지원할 예정입니다.

.NET Framework 3.5 SP1을 포함한 다른 .NET Framework 버전에 대한 지원 일정은 변경되지 않으며, 이는 본 문서에 명시된 대로 계속 지원됩니다. .NET Framework 라이프사이클 FAQ 참고

Why are we doing this?

.NET Framework는 이전에 보안 해시 알고리즘 1(SHA-1)을 사용하는 인증서를 사용하여 디지털 서명되었습니다. SHA-1은 더 이상 안전하지 않은 레거시 암호화 해싱 알고리즘이다. SHA-1을 사용하여 업계 표준 진화를 지원하는 디지털 인증서를 사용하여 서명한 콘텐츠를 폐기합니다.

 

여러 버전의 .NET Framework에서 다운로드 및 사용 데이터를 살펴본 후, .NET Framework 4.6.2 및 최신 버전을 업데이트하여 새로운 디지털 인증서(설치자의 경우)를 지원한다는 사실이 변경 없이 대다수의 사용자(98%)를 충족한다는 사실을 알게 되었습니다. .NET Framework 4.5.2, 4.6 또는 4.6.1을 사용하는 소규모 사용자는 최신 .NET Framework 버전으로 업그레이드해야 합니다. 응용 프로그램은 다시 컴파일할 필요가 없습니다. 이러한 변화의 특성을 고려하여, 우리는 .NET Framework 4.6.2 이상을 목표로 하는 것이 지원과 노력의 최상의 균형이라고 결정했습니다.

 

자세한 내용은 SHA-1 콘텐츠 폐기 관련 지원 문서를 참조하십시오.

 

.NET Framework 4.5.2, 4.6 및 4.6.1이 지원 종료가 되어도, 이러한 버전 위에서 실행되는 애플리케이션은 계속 실행됩니다. 다만, 2022년 5월부터 .NET Framework 4.5.2, 4.6 및 4.6.1 버전에 대한 보안 업데이트를 하지 않습니다. 이는 2022년 5월부터 컴퓨터에 .NET Framework 4.5.2, 4.6, 4.6.1이 설치되면 보안이 취약해질 수 있음을 의미합니다. 또한 문제가 발생하여 기술 지원이 필요한 경우 먼저 지원되는 버전으로 업그레이드하라는 메시지가 표시됩니다.

 

.NET Framework 4.6.2는 약 5년 전에 출하되었으며, .NET Framework 4.8은 2년 전에 출하되었기 때문에 두 버전 모두 애플리케이션에 대해 견고하고 안정적인 런타임이 가능합니다. .NET Framework 4.6.2 및 4.8은 NET 4.5.2, 4.6.1의 호환성이 높은 내부 업데이트(교체)이며 Windows Update(WU)를 통해 수억 대의 컴퓨터에 광범위하게 배포됩니다. 컴퓨터가 WU에서 최신 업데이트를 가져오도록 구성된 경우 응용 프로그램이 .NET Framework 4.8에서 이미 실행되고 있다고 볼 수 있습니다.

 

아직 .NET Framework 4.6.2 이상 버전을 배포하지 않은 경우 애플리케이션을 실행 중인 런타임만 최소 버전 4.6.2로 업데이트하면 지원 상태를 유지할 수 있습니다. 애플리케이션이 NET Framework 4 – 4.6.1을 목표로 구축되었다면 대부분의 경우 변경되지 않고 .NET Framework 4.6.2 이상에서 계속 실행되어야 합니다. .NET Framework 4.6.2에 대해 대상을 변경하거나 다시 컴파일할 필요가 없습니다. 따라서 업데이트된 런타임을 프로덕션 환경에 배포하기 전에 최신 런타임 버전에서 실행할 때 앱의 기능이 영향을 받지 않는지 확인하는 것이 좋습니다.

Resources

다음은 도움이 될 수 있는 몇 가지 다른 리소스:

당사는 귀하의 앱이 최신 버전의 소프트웨어에서 작동하는지 확인하기 위해 최선을 다하고 있습니다. 아직 대답하지 않은 질문이 있으면 도와드리겠습니다. 해결을 위해서는 일반 채널을 통해 Microsoft 지원 서비스에 문의해야 합니다.

 

또한 .NET Framework 4.6.2 이상으로 전환할 때 호환성 또는 앱 문제가 발생하는 경우 App Assure가 있습니다. 호환성 문제를 추가 비용 없이 해결하는 데 도움이 됩니다. App Assure에 연락하여 교정 지원을 요청하거나 요청을 제출하는 데 문제가 발생하는 경우 이메일을 통해 해결할 수 있습니다(ACHELP@microsoft.com).

 

또한 이 게시물에서 다루지 않은 자세한 답변 또는 질문에 대해서는 이 FAQ를 참조할 수 있습니다.

Closing

.NET Framework 4.5.2, 4.6 및 4.6.1은 2022년 4월 26일에 지원이 종료될 예정이며, 이 날짜 이후에는 이러한 버전에 대한 보안 수정 또는 기술 지원을 포함한 업데이트를 더 이상 제공하지 않습니다. 이 날짜 이전에 애플리케이션을 적어도 .NET Framework 4.6.2 이상으로 마이그레이션하는 것이 좋습니다.

원문

.NET Framework 4.5.2, 4.6, 4.6.1 will reach End of Support on April 26, 2022 (microsoft.com)

 

댓글
댓글쓰기 폼
Total
615,875
Today
216
Yesterday
261
«   2021/07   »
        1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 31
07-28 20:07
글 보관함